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Abstract

This document is intended to provide information relevant to using TEXMACS for creating presentations
that will be displayed by various electronic devices and perhaps also printed. Not all TEXMACS features

related to the creation of presentations are explained in detail. Some are not explained at all, but merely
demonstrated. The reader is advised to refer to the excellent TEXMACS documentation for the technical
details. Basic knowledge of TEXMACS is assumed. If this is not the case, refer to to the TEXMACS website
link http://www.texmacs.org/tmweb/help/tutorial.en.html to access a tutorial in order to become
familiar with the user interface and the essential features of TEXMACS. This document is not a TEXMACS tutorial.

It is also not a polished presentation. The structure is that of a presentation, but much of the content is
ordinary paragraph text in a form that would not be appropriate layout for presentation content.The style
is of this document is intentionally informal. Information and commentary is provided related to the general
issues involved with the creation of a presentation as well as the specific issues relevant to using TEXMACS

for this purpose. The TEXMACS source file used to create this presentation in the form of a PDF file may
be used as a template for presentations without much effort.

page break

2



This work is licensed under the Creative Commons Attribution-Noncommercial 3.0 Unported License.

To view a copy of this license, visit

http://creativecommons.org/licenses/by-nc/3.0/

or send a letter to

Creative Commons, 171 Second Street, Suite 300, San Francisco, California, 94105, USA.

no-first-indent

Attributed quotations from copyrighted works may appear in this document under the “fair use” provision of Section 107
of the United States Copyright Act (Title 17 of the United States Code). The license of this document is not applicable
to those quotations.
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TEXMACS Settings Used For This Document

The following TEXMACS settings were used to structure this document as a presentation:

• Edit→Preferences→Printer→Paper type→Legal (could be Letter or other size as required)

• Edit→Preferences→Printer→Printer dpi→300 (this setting as required for printed graphics quality)

• Document→View→Informative flags→Also on paper (not necessary for actual presentation)

• Document→View→Page layout→Margins as on paper (helps see document as printed or exported to PDF)

• Document→Magnification→1.7 (changes size of content)

• Document→Page→Type→Paper

• Document→Page→Size→Legal

• Document→Page→Orientation→Landscape

• View→Shrinking factor→Other...→9 (only affects displayed size of document in TEXMACS)
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TEXMACS Packages Used

The following packages were added to style this document as a presentation (using Document→Add package):

• Generic (default for new document)

• presentation

• compact-list

• slides

• maxima (used for Maxima interactive session)

• varsession (used to add extra styling to Maxima interactive session)

• tmdoc-keyboard (used to add keyboard style like this key )

• tmdoc-markup (used to add menu selection style like this File→Print→Save)
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Introduction (An Inserted Section)

TEXMACS is not a program that specializes in creating sophisticated presentations with fancy transition effects, eye candy,
and multiple media types. What TEXMACS does well is to create a variety of technical documents that include mathematical
expressions such as reports, articles, lecture notes, problem sets, homework, exams and also presentations. The advantage to
using TEXMACS is that the user only needs to be familiar with a single program to do all of these different tasks well without
specialized technical knowledge of other programs or typesetting systems such as TEX or document languages such as LATEX,
Beamer, or TexPower, etc. It is true that familiarity with LATEX may be useful occasionally since TEXMACS can import LATEX
math expressions, but this kind of knowledge is not required. The fact that TEXMACS documents may be exported to PDF

which can be printed, annotated, distributed as files, used as presentations, edited, transformed or enhanced using numerous
PDF editing and manipulation programs makes TEXMACS a figurative “Swiss Army knife“ for creating technical documents
with mathematical content. That TEXMACS offers this kind of “one-stop shopping” makes learning its use productive and
effective for a variety of document creation tasks including presentations.

The assumption is that the TEXMACS document will be exported to PDF for use with some type of presentation display (PC,
laptop, projector, whiteboard, TV, etc.) and possibly distributed as a file, printed on paper using a physical printer device,
or rendered by a web browser. The PDF file format requires little in the way of compromises while offering documents that
are well suited for a variety purposes. In general it is a challenge to accommodate these various uses with a single document
format as a source. TEXMACS documents exported as PDF files intended for use as presentation media have different layout,
style and formatting requirements than documents primarily intended for printing on paper such as reports or articles.
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TEXMACS Presentations — Beamer or PDF

If printing or exporting is not an important consideration, then one option for using a TEXMACS document as a presentation is
to use the beamer style (Document→Style→beamer) and other related packages. The presentation can then be structured
using switches as the means of slide traversal. See the TEXMACS documentation Help→Manual→Laptop presentations for
details. Using the beamer style with switches produces a nice presentation structured as slides. However, if sophisticated
presentation features such as video files or animations are required, there are several options. One is to export the TEXMACS

file to PDF and then use Adobe Acrobat or similar program to add the desired requirements. The ability to include
movies or video may be added to TEXMACS in the future. Displaying graphics of conventional formats is simple. Tables and
lists of various kinds are also easy to include.The informative flags are set to display and print for this document. This is
so the location were page breaks have been inserted is obvious. The author of the presentation determines the transition
for each slide using page breaks. The frame that is the border of this page depicts a reasonable maximum content area
for the layout as a sort of template which uses a 8.5“ x 14” (legal) physical paper size in landscape orientation at 300 dpi.
However, depending on the content, it may be necessary to change the dpi setting so that the required quality of the
PDF output is achieved. This paper size provides an aspect ratio of about 1.65:1 which is a reasonable compromise given
the various devices that may be used for presentation display. A paper size of 8.5“ x 11“ can also be used if desired by
selecting the Document→Page→Size→Letter option. This is a 4:3 aspect ratio. However, some “real estate” will be lost
on the sides of the screen of a typical laptop or projector depending on the aspect ratio of the device used. The advantage
to this is that the presentation may be printed on “standard“ paper as it appears on the screen without “crunching” the
page content or using legal size paper. One way around this if using a PDF reader as presentation software is to zoom so
that the page width fills the screen. However, this may result in the contents of a slide not being visible vertically without
scrolling. Whether this happens or not depends on the page size used and the vertical extent of the content on a slide.
What works may require some trial and error. Note: This slide uses no page break.
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More on Aspect Ratios, Resolution and Printing — (No Frames Used)

The above frame makes that slide unlimited vertically. It may eat into the page numbers and bottom margin. If the content
outside the frame is long for the page, TEXMACS will automatically carry over text to the next page at the right place, but
not if inside a frame. The frame muscles its way into the bottom page margin, and even possibly past the edge of the page.

This slide is mainly more explanation about how to decide on an aspect ratio for presentations. The choice manifests itself
in the page setting. Different display devices have different aspect ratios used to render the PDF file in presentation or “full
screen” mode. Some PC displays use 4:3 aspect ratio while some others have a wider screen size closer to 16:9 or 16:10.
Assuming that the presentation is being created primarily for projection using a “beamer“, there are three typical aspect
ratios that may be good choices: 4:3, 16:9 and 16:10.

Typical resolutions for 4:3 aspect ratio, are 800x600, 1024x768, 1152x864 and 1280x960. Some HDTV screens and beamers
use 16:9. Typical resolutions for these are 1280x720 and 1920x1080. With some more recent devices 16:10 aspect ratio may
be used with resolutions like 1280x800, 1440x900 and 1920x1200. It pays to know your devices.

If the aspect ratio is not right for your display device then you may get black bars on the sides of your presentation slides.
This means wasted display area. It is nicer to avoid this wasted area as much as possible without distortion by “stretching”
the content to fit vertically or horizontally or by zooming. However, the effort required to eliminate every millimeter of black
bars may not be worth it. The other problem arises when printing on paper is also a requirement. Even if a paper size is
used that gives a good aspect ratio for the display device, the paper size intended for printing may not be compatible with
the aspect ratio without some intervention and compromise.

So what are some solutions? One simple solution is to either size the presentation using the paper size intended for printing
and accept any wasted area on the display that results, or use a page size with and aspect ratio close to that which matches
the display device and then set the printer to shrink the content to fit the page.
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Aspect Ratio, Page Size and Printing

If it is necessary to pick one page size then letter is reasonable as a one-size-fits-all choice. However, those that do not mind
doing a little extra work, can have it both ways. There are several methods for printing a TEXMACS presentation document
exported as a PDF file that has a legal page size for an approximate 16:9 aspect ratio used in some display devices:

• First, the exported PDF file can be “crunched” from legal page size to letter which has 4:3 aspect ratio. One way
to do this is by using the Page Crunch (page-crunch) program. This program is a simple GUI to to the psutils

package both of which are available on various Linux and UNIX-like distributions. It is simple to use. Type page-
crunch Enter at the shell prompt and a GUI window appears. Select the PDF input file name and the desired output

file name. Then select the “from“ page size as legal and the “to“ page size as letter and press the See button. The

default PDF viewer is xpdf. This can be changed to whatever reader is being used. In any case, the program may
complain if it does not find the PDF reader it is looking for. Also ignore any messages about “invalid options“ when
the summary is displayed showing the number of pages re-sized. The document is saved in any case using the output
file name with the new page size applied to all pages. The advantage to this is that there is only one TEXMACS source
file used to produce two different PDF files for use as presentations without having to edit the source. The legal size
can be used for larger aspect ratio displays and the letter size can be used for displays that have an aspect ratio of
4:3. Also the latter should print on letter size paper without shrinking to fit.

• Second, when using Adobe Acrobat or Adobe Reader, the File→Print menu selection has options that allow PDF

files to be printed with 2 pages on 1 using portrait orientation. This makes for less paper used for printing and works well.
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Content and Style

Its up to the author to provide slide (or frame) content including lists, math expressions, graphics, tables, etc. About 20-
25 lines or so of text of this style fills the frame NOT including inter-paragraph space. Use page breaks as required to
define transitions between slides.

Entering a shrinking factor of about 9 (using the View→Shrinking factor→Other) changes the displayedTEXMACS document
as shown here to close to one slide vertically as a guide. Some displays may require a different setting. This only changes
the size of what you see on the screen. The contents of the entire document may be “magnified“ more (or less) using the
Document→Magnification menu selection. Changing magnification from the default makes all content larger, but it will
also may affect how page breaks flow the document. If a page (slide) is already full vertically with content, magnification
above that originally used may push the slide content off the bottom of the page. This will require editing to break the
content into multiple slides using page breaks at appropriate places. In general, use one slide for one main point with
related content. This practice will help keep the amount of content of each page consistent with the space available.

The presentation style provides defaults that should work in most needs, but it will depend on the display device used
for the presentation. What will be easy to read and see when content is viewed using a computer display screen may not
be easy to see or read if using a projector, TV, or white board. For all but computers or hand-held devices (pads, readers,
phones, etc.) bigger is usually better. When content is sized to be easily read by an audience using projectors, etc. it may
appear unusually large when read using PC or hand-held displays. PDF readers can help with this issue by using “zoom”
to make the page and contents smaller and hence easier to read. The biggest issue is that magnifying the contents affects
how much content will fit on one page. Again, some trial and error using the intended projection device and audience
feedback will provide a feel for what works. It is relatively easy to change the content size using magnification and then
restructure pages using breaks and slide titles to accommodate the number of required slides to hold the content.

10



Using Frames and Lines or Not

Notice that there was no page break between this page and the last. This worked because the text content of the previous
page hit the “Goldilocks” page length by mere luck and some eyeball guesswork. If the page size is changed then some of
the text may shift down or up. A page break between slides prevents this. Inserting content that is framed makes it easier
to see how much of the page is filled with content. The frame grows with the content. This content is not framed.

However, this content is framed. If this technique is used it is best to put all content inside one “master” frame per slide.
Framed content may be selected using the Insert→Prominent→Framed menu selection.

Another way to do this is to used Insert→Prominent→Underlined with the effect as shown here. The underline moves down
as text is added and so acts as kind of horizontal rule that marks the bottom of the content of each slide as it is added.
In either case of framed or underlined content, when inserting a page break it is best to do this outside of the focus of the
framed content at the page end wherever that happens to fall for the content of a particular page. In this case the page
break was inserted outside the focus of this underlined content as shown by the page break informative flag below.

This text content is outside the focus of a frame (or lines) and therefore is not affected. Any text content added below will
continue to fill this page. Because the content is outside the focus of the frame or lines, TEXMACS will automatically jump
to the next page and the content continues there. However, in order to go to the next page for each slide using text or
content alone with no page breaks inserted at the end of a slide requires adding white space for no other purpose than to fill
up the unused bottom space of each slide. This method makes page editing as individual slides difficult. Keep in mind that
images inserted as content can be re-sized if too big, but these should also fit on the page of each slide without spanning
into the next page. The image size settings and the printer dpi settings will affect how images appear when exported toPDF.
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Other Options — frame the section title

The section title is framed here. This is an option to use instead of framing the content. If this option is used, it is probably
best to use Insert→Prominent→Underlined for content below the title. Still another way to provide some useful way to
structure content is Insert→Prominent→Lines around menu selection used here. This inserts lines above and below content
and has the effect of two horizontal rule lines. The top line stays fixed as text is entered below and the bottom line moves
down as text is enter above. Space above and below the lines can be had merely by entering a blank line using the Return

key. This was done below after the last line of content and above before the first line of text or content. Then the page
break was inserted outside the focus of this content framed by these two lines. The gray line at the bottom of each page of
the source TEXMACS file is intended to indicate the physical extent of the page itself. These gray page lines will not appear
within a printed or exported file. Also, what are not displayed in the TEXMACS source file are page numbers that will be
inserted automatically at the bottom of each page of the exported PDF file. Too much content vertically may overlap the
page numbers of the bottom margin area in the printed (exported PDF) file.

Using white space this way to provide some padding wastes some content space but looks nicer than framed content when
used for the whole page. Content can still be framed inside the focus of these lines. Keep in mind though from a style and
layout point of view, using too much of this sort of content treatment can be more distracting than helpful.

Too many frames? Framed content inside “lines around” content.
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Archimedes Was Framed
Framed content of this slide is in the “master” frame of the page. A graphics file is inserted here. Note that the dpi setting
interacts with the TEXMACS image size setting (72 px by 96 px used here) to affect the size displayed in the exported
PDF file. The source image used with TEXMACS has a size of 460 px x 600 px. The printer 300 dpi preference setting
has the effect of increasing the dimensional size of the image in the PDF file with fixed TEXMACS image size settings.
The TEXMACS image size settings have to be relatively small in the TEXMACS document to offset the image size with
this dpi setting. With some extra work, the size (in pixels) of the image itself may be reduced to better agree with the
TEXMACS settings using an image editing program. It is almost always the case that a source image file size a little larger
than needed for display or print is better than smaller.

Figure 1. Archimedes
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A Minimal Maxima Session

Framed content. An interactive Maxima session. The varsession package was added to provide the colored boxes
automatically This example only scratches the surface on what can be done with TEXMACS interactive sessions.

(%i1) limit(x^2,x,2)

(%o1) 4

(%i2) disp(’limit(x^2, x, 2)=limit(x^2, x, 2))$

lim
x→2

x
2 =4

(%i3) disp(e^(i*%pi)+1=%e^(%i*%pi)+1)$

e
πi +1 =0
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Some TEXMACS Mathematical Expressions

(esin x + sin ex)′ = (esin x)′+(sin ex)′

= (sin x)′ esinx + (ex)′ sin ex

= esinx
cos x +ex

sin ex

∫

0

∞ dx

1+x
2

The alternative rendering:

∫

0

∞

dx

1 +x
2

〈

a

b + c

∣

∣

∣

p

q + r

∣

∣

∣

a

b + c

〉

Lots of capability not shown. See the TEXMACS documentation.
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The Socratic Theorem

Framed content used well without a master frame for entire page. Color can help make distinctions.

Theorem 1. (Socrates) The Kind of Life Not Worth Living Theorem

Proposition. The unexamined life is not worth living.

Proof. Still working on this part. �
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Styling the Background

A style comment not related directly to content or layout involves background treatment. The menu selection Document→
Color→Background can be used to alter the color or “texture“ of the page background. A pure white background can be
hard on the eyes using projectors. Depending on the selection the resulting increase in the exported PDF file size can be
significant as well as the time required for conversion. Selecting merely a color to be added to the background does not result
in larger file sizes or export times, but may be a printing issue since a printer may attempt to print the color in some fashion.
If a printer is used, this may require the user to change the printer settings to avoid this color issue with the background.
It is not recommended that a texture is added using TEXMACS.

The “textured paper” background look used by TEXMACS is tiled. This means that a relatively small image is repeated across
and down filling the page. This can slow the rendering of each PDF page noticeably. The exported PDF file sizes may
be extraordinarily large and the conversion processing time will be significant if a textured background is used. Except for
very small documents TEXMACS may even crash and exit while converting a file to PDF with a textured background.

The best choice if printing is an issue may be to add a background texture or color to the exported PDF file to be used
for presentation using a program like Adode Acrobat or other PDF manipulation or editing program and distribute the
original version for print without textured or colored background. In this way, only one TEXMACS file is required and only
one PDF file is exported for either purpose. Backgrounds added using Adobe Acrobat can be set to be invisible when
printing. The problem with this is that some readers other than Adobe Reader may not display the background at all
— print or not with this file setting on the background. It appears this feature may be unique to Adobe Reader and
Acrobat. Acrobat can tweak the background image in various ways. However, it is best to size and edit the image using
an image editing program to prevent possible side effects caused by tweaking the background image with Acrobat.
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Presentation Software

There are many programs that may be used to render a PDF file for presentation. Adobe Acrobat and Reader both
have “full screen” modes that may be used for rendering a PDF file in a presentation format. Evince also has a similar
viewing mode that may used for this purpose. For any others the user will have to check the documentation of the program
in question to see if there exists a viewing mode suitable for presentation purposes.

Users that desire a standalone program intended specifically for rendering PDF files for presentation may find the
Impress!ve program does this well and also includes some nifty features such as an overview screen, transitions, highlight
boxes , spotlight effect and zoom using the mouse or keyboard. These features make Impress!ve impressive. Visit the
project website for more information: http://impressive.sourceforge.net. The program is written in the Python

programming language. There is no charge for downloading or using this program.

Also worth a look is PDF Presenter. Like Impress!ve, PDF Presenter is dedicated to the task of PDF file
presentation. However, this program emphasizes several annotation methods as well as a “whiteboard“ mode that allows
the presenter to switch to a whiteboard display that can be used in a number of ways. PDF Presenter is written in the
Java programming language and there also is no charge for downloading or using this program. Visit the project website
for more information: http://pdfpresenter.sourceforge.net.
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Final Comments
There are a number of different software programs for creating presentations. These all have their advantages and
disadvantages. It is the opinion of the author that while some of the features of these programs are nice to have, most
of these are not necessary if the goal is to merely create functional presentations of technical material involving mathematical
expressions. Most technical audiences are not “wowed“ by all the “gee whiz“ eye-candy, gingerbread, and nifty effects. Using
TEXMACS with the beamer or presentation styles and other packages available as required should meet the presentation
needs of most people for creating functional technical presentations.

That TEXMACS is easy to use for this purpose may surprise some. While it is true that getting used to a different environment
is required, the good news is that TEXMACS makes matters easy in that it relieves the user of the formal details by using
styles and packages. In fact it is so easy, it is this fact that is hard to get used to. This is not to say that no “tweaking” is
possible, but the big decisions are already made. Those creating TEXMACS document styles and packages are experienced in
typography and style. Users can always write their own styles and packages with some effort if necessary. While this may
require some time and research, it is by far and away easier than learning all the intricacies of LATEX and related presentation
packages. TEXMACS frees the user to focus on content and not typography, style, and layout which are arts in themselves.

The fact that TEXMACS exports to PDF format allows for much in the way of possibilities for enhancing presentations using
PDF editing and manipulation software. Other benefits include the ability to “crunch” the page size, print the file to paper
in various ways, distribute the file, annotate the file, render the file using web browsers as well read the file using PC displays
as well as all types of hand-held devices. All of this makes TEXMACS a good choice for not only creating presentations, but
also for other types of documents with mathematical expression content. The ability to include sessions that interface to
programs such as Maxima make TEXMACS a unique document creation environment.
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